Date:  03/11/2008 06:37:08 PM Msg ID:  003700
From:  David Hempy Thread:  003698
Subject:  Re: \"Script \"index.fwx\" is invalid or no
Sent by FoxWeb Support on 03/11/2008 03:48:18 PM:
The symptoms you describe suggest that FoxWeb is unable to see index.fwx.  At first I suspected that this was due to user rights (may be the FoxWeb service user does not have rights to this file), but I tested this theory and got a different error (Error in FoxWeb Foundation Program).  The only way I could reproduce the problem is by setting the Hidden flag of index.fwx, which effectively hides it from FoxWeb.  I assume that this is not the case here, right?
Yes, I thought the same things.  File permissions don't appear to be the problem.  The file is not hidden.  I took another file in the same directory ("about.fwx"), which is regenerating into about.fxp without trouble, and renamed it to index.fwx (after first renaming the original index.fwx to something else).  I hit index.fwx and got the same error, and no .fxp file was generated.
I renamed index.fwx back to about.fwx, and it again would generate about.fxp just fine. 
Just before this, I rebooted the server, with no improvement. 
Try temporarily running FoxWeb as a regular application (as opposed to a service), to see if this makes a difference.  If it does, then the problem is
I can't believe I didn't think of that!  *blush*
I just did this, and learned little.  There were no on-screen errors or dialogs. I could see from printed debug comments that fw_enter was executing to the point of returning true when I hit index.fwx.  No further lines were printed...normally the called script prints a number of things.  I could see that fw_exit was NOT executing, based on its debug comments not appearing.  

When I hit about.fwx, I saw fw_enter and fw_exit  both run, as well as debug prints from within the script itself.  
The channels are not restarting or hanging.
I found no entries in the error log (in FoxWeb Control Center), and no entries in FWStart.log.  Although I'm dubious that I'm looking at the correct FWStart.log...the most recent entry is Jan 17, despite today's reboot.  Should I be looking in Program Files\FoxWeb\AppData\FWStart.log ?
In the Application Log, I did see two warnings I'm not familiar with:
Windows cannot unload your classes registry file - it is still in use by other applications or services. The file will be unloaded when it is no longer in use. 
Windows saved user WEBTEAM\foxweb registry while an application or service was still using the registry during log off. The memory used by the user's registry has not been freed. The registry will be unloaded when it is no longer in use.

 This is often caused by services running as a user account, try configuring the services to run in either the LocalService or NetworkService account.

I didn't see anything relevant in the Security or System Logs.

I set FoxWeb back to run as a service and to keep .prg files.  Same error in the browser, and no index.prg file was created.


 That's all my clues for now.  Anything else I should be checking?