Date:  04/28/2009 11:48:44 AM Msg ID:  003956
From:  FoxWeb Support Thread:  003951
Subject:  Re: Please, help!
The error you are getting is a VFP error and is described as follows:
An internal call to the GetPrinter( ) function has failed. Visual FoxPro calls this function through either PRTINFO( ) or SET PRINTER TO.
The only situation where FoxWeb ever tries to set the printer is for the PDF printer driver. Are you running FoxWeb 4.X? Could it be that your PDF printer driver is damaged, or that there's a problem with the print spooler on your server? Try setting the "PS or PDF printer" setting to <none> in the FoxWeb Control Center to see if this helps.
FoxWeb Support Team email
Sent by Carlos Fuertes on 04/28/2009 10:53:54 AM:
I have tried the following:

- Using the original Authform.fwx instead of mine one. In fact, my Authform is the same as the original except for text translation into spanish and some pictures (I obtain the same result)

- Running http:/localhost/examples/download.fwx, as I think this sample script doesn't call the Auth object (same result)

I don't know what's happening, but it's very strange. This application has been working fine in this computer and it is running good in other servers.

Sent by FoxWeb Support on 04/27/2009 04:40:25 PM:
I have never see this error before. Does it only happen in pages that use the Auth object? What happens if you remove the call to Auth.Authenticate?
Do you use a custom AuthFormFile by any chance?
FoxWeb Support Team email
Sent by Carlos Fuertes on 04/26/2009 12:04:59 PM:

I have a problem. When I try to run a foxweb script I get this message:

There was an error during the interpretation of your request

Message:     Error accesing printer spooler

The script has been working fine until now and it calls the authentication form (nothing about printing is involved yet).
In fact, when I try to run the contactmine sample (http://localhost/contactmine2/contact.fwx) I get the same error

The only change I have made in my computer is to install MS Internet Explorer 8

I use IIS, Vindows Vista Business and Foxweb 4.3

I have tried rebooting my PC and also accessing from other computer in my intranet running MS Internet Explorer 7

Please, any help will be apreciated!