Date:  11/17/2011 05:05:03 PM Msg ID:  004378
From:  Steve Moore Thread:  004375
Subject:  Re: foxpro versions
Its been a couple of years since I fooled with it but as I recall the fgets() used to allow strings longer than 256 chrs but that was changed in 9. I don't have a copy of vfp9 installed any more so I can't answer definitively at the moment. I havevfp9 files but not a working installer. Looking into that as well... :(
 
So if the vfp 9 dlls install with 4x, I just select 9 on install, but doesn't it also ask me to point foxweb config to the vfp.exe? I will just have to test the scripts to see if they break in v9. It may be that it only affects other functions/programs not required by the web delivery scripts.
 
Also, if I am using on older version to write the code, will foxweb automatically compile the code once placed on the server?
 
I hope to build a test box to check all this out over the weekend, I will see what happens.
 
Finally, can I have 3x and 4x installed on the same machine? And any ideas on finding a legit copy of vfp9?
 
 
Sent by FoxWeb Support on 11/17/2011 02:04:51 PM:
FoxWeb 4 installs the VFP 9 Run-Time DLLs, which is all you need on your server. Programs directly referenced in the URL, or called via Server.Execute() are compiled automatically, but all other programs will need to be compiled with the fwAdmin script or the fwCompile object.
 
Of course all this assumes that you can get your code to run properly with VFP 9. I am not aware of any breaking changes related to string manipulation in VFP 9. What exactly are you referring to?
FoxWeb Support Team
support@foxweb.com email
Sent by Steve Moore on 11/17/2011 10:42:04 AM:
At present I have vfp9 files but no installer, is the installer necessary, or can I just use the vfp9 files and point foxweb to it? I'm assuming vfp9 would need its registry entries to function properly yes?
 
And finally, can I keep both 3x and 4x installed on the same machine?
 
Thanks again.
Sent by Steve Moore on 11/17/2011 05:01:54 AM:
 I upgraded from 3x to 4x to run under 2008 rs service. No support for vfp5? Where can I get later versions of vfp? ver 9 changed some underlying routines that handle strings and wont work without requiring me to do do major rewrites unfortunately. I have the vfp 6 libs but not exe. Any ideas? Running 3x under 2008 seems problematic so far. Thanks, and sorry for my repeated inquiries.