Date:  01/17/2014 12:17:31 PM Msg ID:  004657
From:  Steve Moore Thread:  004651
Subject:  Re: strange configuration problem
I found one difference between the working/non working sites:
 
Under IIS 7 Handler Mappings:
 
For the domain that works... Handler column is listed as IsapModule
 
for the two that don't... this column says path to foxweb.dll
 
when I double click the entry both come up and say foxweb.dll

so... I used "add module mapping" to recreate the entries and viola it worked! problem solved.
 
 
Sent by Steve Moore on 01/17/2014 12:01:14 PM:
error reported on local server:
 
500.21 Handler has a bad module "ManagedPipelineHandler" in its module list.
 
mappings are same for domain that works and ones that don't... both point to foxwebdll, get, head, post, script.
 
No other entries in application or event logs.
 
Sent by FoxWeb Support on 01/17/2014 11:28:32 AM:
Usually IIS provides additional information in the case of 500 errors. These are not necessarily reported in the browser (although they may -- make sure that "Friendly Error Messages" is disabled in IE), but they are probably logged in the Windows Event Log.
FoxWeb Support Team
support@foxweb.com email
Sent by Steve Moore on 01/16/2014 10:37:28 PM:
I have a Windows Server 2008 R2 installation that has been running a long time. The server has 3 foxweb licenses configured. For some reason, 2 of the three virtual servers have stopped working always returning a server 500 internal error. The first server works fine as expected.
 
All of the virtual servers were working at one time. There was a server rebuild at some point, not positive if this is when the issue began but doubtful.

The serial numbers are:

040-02057 (works)
040-00457 (500 error) 
040-00458 (500 error) 
 
It is version 4.5 vfp 9. It is running as a service. 1x compatibility is checked (tho I don't think it's needed).
 
I have tried numerous approaches to troubleshooting, including changing program roots. I am not using the server's directory mappings in the foxweb control center.
 
IIS reports that the sites are working as expected. I can load static pages ok. But I cannot get Foxweb scripts to run using but one of the virtual domains (the first one). The permissions appear to be the same for all servers.
 
I also have one other very strange issue with the server now that I have never seen before. The websites load fine using the domain names but not using the ip address. For example:

http://domain.com/page works,
 
http://ip address/page returns 404
 
This problem is common to all websites on the server, scripted or not. I, of course have seen the opposite result whenever DNS is incorrectly configured but have never seen the reverse to be true. It's very strange. I don't know if the problems are related since it applies to all sites on the server.
 
Any help with either issue would be greatly appreciated.
 
Steve
Foxweb user for 15 years!