Date:  06/24/2014 10:41:44 AM Msg ID:  004704
From:  FoxWeb Support Thread:  004699
Subject:  Re: Foxweb already started...
The FoxWeb Control Center should always ask for UAC permission to gain elevated status. If it does not, it probably means that UAC was disabled on your server. The detection code does not require elevated permissions, but this may be an indication of other issues related to your server or VFP setup.
Does the FoxWeb Control Center detect whether FoxWeb is running if you start it as a regular application, rather than as a service? 
The detection code itself is very simple and you should be able to run it inside VFP:




M.SFWStart=OpenSemaphore(SYNCHRONIZE, 0, "Global\FWStart")

IF SFWStart != 0

? "FoxWeb is running"


? "FoxWeb is stopped"



FoxWeb Support Team email
Sent by Ali Koumaiha on 06/24/2014 06:27:13 AM:
When i run the foxweb, it does not prompt to elevate the permission.
Though, i tried "right-clicking" and selecting "Run As Administrator"
I use the same account that i installed foxweb originally with, which is the Administrator account.
and same thing happen.  Still says "Start" even though, it is already started.
btw, this is FoxWeb 4.5
Sent by FoxWeb Support on 06/23/2014 12:29:37 PM:
The FoxWeb Control Center uses semaphores to determine if the service is running. The only explanation I can provide for not being able to detect the run status correctly is permissions, or some other security configuration that is affecting this on your Windows 2008 server. I realize that you have tried using the Administrator account, but I don't see how anything else could be the culprit. This particular functionality is extremely simple (about 8 lines of code) and has not changed in many years.
Can you confirm that the FoxWeb Control Center causes the User Account Control (UAC) dialog to pop up when being started? This particular functionality does not need elevated permissions, but I'm just trying to eliminate all possibilities.
On the meantime, you should still be able to manage the service using the regular Windows Services dialog. 
FoxWeb Support Team email
Sent by Ali Koumaiha on 06/16/2014 07:39:45 AM:
 On one of our server, we are running 2008 R2, foxweb is working great.
however, when i open the foxweb control panel, it says "Start" even though it is started.
it is running as service. Even when i right-click on foxweb control and say "run as admin"
however on our other server 2012, its working like it should.  and that's set as service as well.
I am remoting into the server (both of them actually) using RDP
how can that be fixed.
ps: foxweb 4.5 on both (2008 r2 and 2012)
VFP9 SP2 on both

everythig check under configuration except: Full Paths in URLs and Keep PRG (both are not checked)


I am curious if i have to be logged in using the same username as the one that installed it (Administrator) vs my admin normal username.


the server 2012 i am logging in as Administrator, where the other one is my regular username with "Admin powers"