Date:  11/26/2019 04:59:59 PM Msg ID:  005002
From:  FoxWeb Support Thread:  005001
Subject:  Re: 2012/HTTP Error 503/Unavailable service
Art,
 
If you are unable to connect to the root of your web server (the server's static home page), then I suggest that you post your question on Stack Overflow or on the Microsoft forums.
FoxWeb Support Team
support@foxweb.com email
Sent by Art Bergquist on 11/22/2019 03:04:14 PM:
Hi,
 
We're looking to move a FoxWeb web site from Windows Server 2008 R2 to Windows Server 2012.  When I redirect my local hosts file (C:\Windows\System32\Drivers\etc\hosts) to point to the new server and try to go to a FoxWeb (.FWx) page on the new server, I get the following error message:
HTTP Error 503. The service is unavailable.
I get the same error even if I try to go to a non-FoxWeb page on the site.  That indicates to me that it's an issue with IIS, not with (the) FoxWeb (Control Center).
 
One thing I notice is that each time I refresh/retry to go to the web page that, at some point, the Application Pool for the FoxWeb web site stops.  I keep re-starting the Application Pool but the same thing recurs each time I refresh/retry to go to the web page.  (I have also run 'iisreset /noforce' from the Command Window and stopped/restarted the User Profile Service in Services.)
 
As far as I can tell, all settings on the Windows Server 2012 server are established per the "Configuring the Web Server" section of the FoxWeb help (http://www.foxweb.com/document/index.htm?page=/document/WebServer.htm).
 
I've got a couple questions:
  1. Is there something else I should try?
  2. Is there an easy way to compare both IIS settings between two servers?
I just Google-d the following:
 compare iis settings between Windows Server 2008 and Windows Server 2012
but thought I'd first check here since it looks involved (perhaps this will be a moot point if I get an answer to #1 above)
TIA,
 
Art Bergquist