Date:  11/14/2007 04:32:09 PM Msg ID:  003585
From:  FoxWeb Support Thread:  003582
Subject:  Re: No Channels/permissions/service account
It sounds like there was a problem, which caused the "The Resource file..." message, whenever the foxweb_service user tried to run VFP (see KB article 114269).  The resulting message box prevented channels from initializing properly.  Of course there was no way for you to see this while FoxWeb was running as a service, so the result was what you saw:  The FoxWeb server got impatient waiting for the initial channel check-in and continuously restarted them.

Once you tried running VFP (or FoxWeb) interactively, while logged in as foxweb_service, you were able to see and clear the message, which allowed this user to run VFP.
FoxWeb Support Team email
Sent by David Hempy on 11/14/2007 09:49:45 AM:
I had a peculiar problem, with a peculiar solution.  I'm sharing it here in case anyone else runs into this.

I installed FoxWeb 4.0 and VFP 9.0 SP1 on a brand new server.  (BTW, this is not the machine we worked on last week, Pandelis...completely unrelated.)

FoxWeb runs just fine as an application, when I am logged in.  (I have admin rights.)

When I ran it as a service, logged in as foxweb_service (the account FoxWeb has been running as for years on our servers, with permissions limited appropriately), I got back in the browser the "No Channels Active" FoxWeb message.  (Notably, my browser (FireFox) offered to save the file, and would not display it.  I suspect the MIME type was bad, but I didn't chase that issue down.)

No entries in the FoxWeb error log.
No entries in the Windows event log.
Channels shown restarting (but not being killed) in fw_start.log.

I changed the service to log in as me, and things worked fine.  I changed it back to foxpro_service, and it broke.  At this point, I was pretty certain it was a permissions problem.

I added explicit permissions for foxweb_service (actually, for a group to which that this account belongs) to the VFP, FoxPro, CGI, and web root directories.  No improvement.

I then logged out of the server, logged in to the console as foxweb_service, and started FoxWeb as an application (I think...might have been as a service, but I don't think so.)  This time, a dialog popped up that read:

    "The resource file is not valid.  Overwrite it with a new empty one?  Yes/No"
I selected "Yes" and everything went fine.

I shut down FoxWeb, logged out, logged in as myself, and started FoxWeb as a service, running as foxweb_service, and everything went smoothly.

At this point, I'm a happy camper.  I'll follow up if anything comes up.  Hope this helps if anyone else runs into this.


David Hempy
Internet Database Administrator
Kentucky Educational Television
(859)258-7164 - (800)333-9764